Page 1 of 1

rFactor crashes because d3d9.dll

PostPosted: Wed Oct 17, 2012 6:31 pm
by Ube1
Hi all,
I saw rfdynhud plug in and i wanted to install it. First i had problem with java, after i installed java 6, editor opened.
Then I done everything like in read me, and now when i start game, i mean session, practice (off or online doesn't matter), my rf game crashes to desktop. I deleted d3d9 it works fine, but with original HUD. I tried it with other mods, same problem.
I'm using CTDP 2006 mod.
Thanks in advance.

Re: rFactor crashes because d3d9.dll

PostPosted: Fri Oct 19, 2012 1:08 pm
by Marvin
Difficult to say. Are you using version 1.3.0 of the plugin? And have you installed the 32 Bit version of Java 6?

Re: rFactor crashes because d3d9.dll

PostPosted: Fri Oct 26, 2012 1:51 pm
by Ube1
Yes and yes.
First i had problem, i couldn't launch editor, then i installed Java 6 32 bit. After that launcher opened.
ps: i'm using Windows 7 PRO 64bit with GeForce GTX470 and 306.23 drivers.

Re: rFactor crashes because d3d9.dll

PostPosted: Tue Oct 30, 2012 11:42 am
by Marvin
Hard to say. You could attach the rfdynhud.log file and one of the heap dump files, that are produced when the JVM actually crashes. You'll find them in the rf installation folder (IIRC these files are named something like hs_12313123.log).

Re: rFactor crashes because d3d9.dll

PostPosted: Wed Oct 31, 2012 1:39 pm
by Ube1
hs_err_pid5300.log
(12.08 KiB) Downloaded 5182 times

Here! I hope it's the right one because i have 6 of them. (hs_err_pid5024...)

Re: rFactor crashes because d3d9.dll

PostPosted: Wed Oct 31, 2012 2:51 pm
by Ube1
ps: i forgot to mention, rfDynHUD_v1.0.1 is working just fine. But i think it's incorrect because engine life is running out fast, in race session i got engine to -800% and still was working. Also with brakes and tires.
Thanks

Re: rFactor crashes because d3d9.dll

PostPosted: Wed Oct 31, 2012 9:51 pm
by Marvin
Ube1 wrote:Here! I hope it's the right one because i have 6 of them. (hs_err_pid5024...)


It doesn't matter. Each JVM-crash produces one of these. I assume, they're all the same.

Unfortunately I cannot see the reason in that file. It doesn't even seem to execute any Java code when the crash happens.

Could you please also attach the rfdynhud.log?

Ube1 wrote:ps: i forgot to mention, rfDynHUD_v1.0.1 is working just fine. But i think it's incorrect because engine life is running out fast, in race session i got engine to -800% and still was working. Also with brakes and tires.


Event if I theoretically got the correct math for brakes wear, it never really worked. So you shouldn't pay too much attention to this display. But engine wear should be correct. It is very well possible for this value to go below 0%, if the engine lifetime has a variance. You can setup the WearWidget to never go below 0% (keyword: 100%-base). But if the engine has a variance - like all of the CTDP 2006 cars do - it won't blow up at exactly 0% then.

Re: rFactor crashes because d3d9.dll

PostPosted: Thu Nov 01, 2012 2:09 am
by Ube1
Here is whole folder log.
log.zip
(8.21 KiB) Downloaded 5613 times

Re: rFactor crashes because d3d9.dll

PostPosted: Thu Nov 01, 2012 11:44 am
by Marvin
It really looks strange. It simply crashes at a point, where nothing special is done. Tbh. I am not actually sure, if I can read the point, where it crashes.

The only thing, that is different to my tests, is the track. Have you tried it with a different track? I have never seen rfDynHUD to crash because of the track. But who knows.

And you could try to re-install Direct3D (DirectX). But this is just a guess as well.

Re: rFactor crashes because d3d9.dll

PostPosted: Thu Nov 01, 2012 2:21 pm
by Ube1
Different track, newest directx installed again the same.
It loads the track, then after 1 second in garage it crashes and that say "rFactor.exe stopped working. Detecting problem." Also i let wind to try detect it but with no success.
Btw thanks for your help.

Re: rFactor crashes because d3d9.dll

PostPosted: Sat Nov 03, 2012 7:41 pm
by Marvin
I think, I have to give up here. Sorry. I cannot tell you more than to try to reinstall Windows, which seems a bit overkill. Have you tried your rFactor installation on a different system?

Re: rFactor crashes because d3d9.dll

PostPosted: Sun Nov 04, 2012 2:26 pm
by Ube1
Marvin wrote:I think, I have to give up here. Sorry. I cannot tell you more than to try to reinstall Windows, which seems a bit overkill. Have you tried your rFactor installation on a different system?

No. I'll try it on another PC, but i cannot reinstall Widows. It's fresh install and i know it all works just fine. About another version, only like i said on another PC, because mine is Genuine.
BTW thanks a lot. When i try on different PC I'll write it here what's going on. :)

Re: rFactor crashes because d3d9.dll

PostPosted: Tue Apr 16, 2013 11:08 pm
by koma56
Hello, maybe it´s too late but I want to know if you resolve your problem because i've got exactly the same and I don't find solution.....

Re: rFactor crashes because d3d9.dll

PostPosted: Thu Apr 18, 2013 3:19 pm
by koma56
Hello. I've got exactly the same problem and I want to know if you found a solution, and what is it please ?
I already install it in another computer and there was no problem but with my new computer I've got the problem than yours.

Re: rFactor crashes because d3d9.dll

PostPosted: Mon May 19, 2014 4:19 pm
by Ube1
If someone is still having problems with this, I found solution. MSI Afterburner is crashing game. When I turn it off it works just fine ;).